FAQ FAQ  Forum Search   Register Register  Login Login

Metro 2033 Stuttering

Post Date: 2012-04-21

 Post Reply Post Reply
Author
  Topic Search Topic Search  Topic Options Topic Options
Vladmar View Drop Down
Newbie
Newbie

Email address used to purchase matched with forums account email.

Joined: 24 Feb 2012
Online Status: Offline
Posts: 16
  Quote Vladmar Quote  Post ReplyReply bullet Topic: Metro 2033 Stuttering
    Posted: 21 Apr 2012 at 12:56am
My Specs:
ASUS P8Z68-V PRO/GEN3
i5 2500k @3.30ghz (Not OC'd)
8GB Adata Xpg Gaming Series DDR3 @ 2000mhz
2 ATI Radeon 6950's running in CrossfireX both running 820/1250
Corsair GS800 Gaming Series 800 Watt power supply
Corsair A70 CPU Heatsink

Alright, I recently got my PC back from a serious RMA which I know has nothing to do with this problem. I was originally playing with just a single 6950 but wanted more performance and my mobo is CrossfireX ready so I installed a 2nd 6950 I got on Newegg. All my games run excellent, getting fantastic framerates and both my cards are staying nice and cool. However, when I play Metro 2033 I have all settings maxed out running at 1920x1080. I am getting game stuttering occuring every 1-2 seconds. It is really annoying and although the game is still very playable it is hurting my experience with the game considerably. I have updated my drivers and both cards are running on the same drivers as well already checked that out. I've tried vertical sync off an on with no effect. I've tried altering the video settings including the PhysX and DirectX version settings. Nothing I have tried has work. I have even disabled DEP for Metro 2033 and still nothing. Is this just an unfixable problem I have to deal with? a single 6950 is not enough to run Metro 2033 on max settings above 60fps which is my ideal framerate for gaming and 2 of them easily do that but then I get the stuttering which is annoying as hell. If anyone has had this problem and has found out how to fix it please let me know.

Back to Top
bprat22 View Drop Down
DS ELITE
DS ELITE

Email address used to purchase matched with forums account email.

Joined: 08 Jun 2011
Online Status: Online
Posts: 10496
  Quote bprat22 Quote  Post ReplyReply bullet Posted: 21 Apr 2012 at 6:14am
Hi Vladmar...Please don't take this wrong, but the cf bridge is hooked up?
 
Also, I'm not surprised the cf 6950 is having trouble.  Metro is one of the hardest gpu games and the single 6950 plays it on very high settings only in the 30's fps.  So a cf 6950 will struggle to keep it in the 60's.  Alot of people have complained of cf 6950 actaully looking worse than a single even though fps are higher.  It could be the lack of better drivers for that card.
 
I would turn down the settings and enjoy much smoother game play.  Quality would probably be just as good.


Edited by bprat22 - 21 Apr 2012 at 6:26am
Back to Top
Vladmar View Drop Down
Newbie
Newbie

Email address used to purchase matched with forums account email.

Joined: 24 Feb 2012
Online Status: Offline
Posts: 16
  Quote Vladmar Quote  Post ReplyReply bullet Posted: 21 Apr 2012 at 4:56pm
Yes, the cf bridge is hooked up and secured. I've seen videos of people playing Metro 2033 on max settings with crossfire 6950s and they were getting 60-80 fps with not stuttering. Maybe it's the drivers. Meh, idk but thanks for your help though.

Back to Top
Vladmar View Drop Down
Newbie
Newbie

Email address used to purchase matched with forums account email.

Joined: 24 Feb 2012
Online Status: Offline
Posts: 16
  Quote Vladmar Quote  Post ReplyReply bullet Posted: 22 Apr 2012 at 4:59am
I uninstalled Catalyst 12.3 driver. Tried 12.1a, 12.1, and now 11.11 and still the same results every time. I bumped all the settings down in game as well and still getting stuttering. No idea what is causing it. 
Back to Top
bprat22 View Drop Down
DS ELITE
DS ELITE

Email address used to purchase matched with forums account email.

Joined: 08 Jun 2011
Online Status: Online
Posts: 10496
  Quote bprat22 Quote  Post ReplyReply bullet Posted: 22 Apr 2012 at 8:02am
So many having trouble with Metro.  All I can suggest is what has worked for others.........Turn off Adv Physx, Adv dof and tessellation.   For some running in DX 10 has been the fix.  
 
Some have no problem and others alot of problems.  I played the demo on high settings, DX11, adv Tessellation and dof on, at 1920x1080 with a gtx560 and it played smooth.  I never checked fps but it looked good.  How the full game would do I can't say.
 
 
 
 
Back to Top
FrankW View Drop Down
DS Veteran
DS Veteran

Email address used to purchase matched with forums account email.

Joined: 22 Feb 2010
Online Status: Offline
Posts: 1401
  Quote FrankW Quote  Post ReplyReply bullet Posted: 22 Apr 2012 at 8:13am
Hi Vladmar,

1. Are you playing on line or single player on your computer? I am thinking you might be seeing lag caused by your connection.

2. Are you getting stuttering on other games or just metro?

3. Have you tried playing with AA shut off? Some solve this problem with turning AA to 2X but I would just turn it off and see if it makes any difference.

4. Make sure the driver you are using has a date later than September 2011.

Frank



HAF 922
EVGA X58 LE
6GB DS Certified
Corsair 750TX
HDD-1TB
Optical Drv
ATI Radeon 5870
Back to Top
Vladmar View Drop Down
Newbie
Newbie

Email address used to purchase matched with forums account email.

Joined: 24 Feb 2012
Online Status: Offline
Posts: 16
  Quote Vladmar Quote  Post ReplyReply bullet Posted: 22 Apr 2012 at 5:27pm
I'm playing on single player via Steam but I do that for other games and experience zero lag. No stuttering from other games, i've tried with everything on low, DX10, DX9. I've tried turning up my gpus still the problem persists with everything I try. It's a fun game I guess they just did a horrible job optimizing it for people.

Back to Top
xii View Drop Down
Senior Member
Senior Member
Avatar
Email address used to purchase matched with forums account email.

Joined: 25 Feb 2012
Online Status: Offline
Posts: 951
  Quote xii Quote  Post ReplyReply bullet Posted: 23 Apr 2012 at 12:35pm
I had this exact same problem.  After so much work..

I ended up formating.  My PC was not a DS system.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.1992188 seconds.